Fix or reduce overly verbose logs and warnings

- The nginx server names bucket was too small, this has been increased
- Nextcloud had too high of a log level, this has been decreased
- Matrix had a warning due to using the default matrix.org keys. This is
  fine so has been ignored
- A special *evaluation* warning for you: we previously used an old
  option name, by virtue of some strange behavior in inheriting system
  config that I do not fully understand. Regardless, we can fix this by
  filtering out the dead option name

Change-Id: I97c517073fb76caed1d000290fd1fad15000057f
Reviewed-on: https://git.clicks.codes/c/Clicks/NixFiles/+/189
Tested-by: Skyler Grey <minion@clicks.codes>
Reviewed-by: Samuel Shuert <coded@clicks.codes>
diff --git a/modules/common/matrix.nix b/modules/common/matrix.nix
index 015c3f4..b871900 100644
--- a/modules/common/matrix.nix
+++ b/modules/common/matrix.nix
@@ -10,6 +10,7 @@
     settings = rec {
       server_name = "clicks.codes";
       auto_join_rooms = [ "#general:${server_name}" ];
+      suppress_key_server_warning = true;
       enable_registration = true;
       registration_requires_token = true;
       allow_public_rooms_over_federation = true;