Move jinx to system and assign postgres database
We wanted an easy way to view the jinx logs and to avoid using a
separate user account which is more complicated to operate, and has more
challenges in deployment, than a normal systemd service
Change-Id: I436247a14925316ec3dcd77fb18875dc35c69560
Reviewed-on: https://git.clicks.codes/c/Infra/NixFiles/+/398
Tested-by: Skyler Grey <minion@clicks.codes>
Reviewed-by: Samuel Shuert <coded@clicks.codes>
diff --git a/modules/common/mailcow.nix b/modules/common/mailcow.nix
index 9073d56..f046684 100644
--- a/modules/common/mailcow.nix
+++ b/modules/common/mailcow.nix
@@ -24,7 +24,12 @@
certs = lib.pipe mailACMEHosts [
(map (name: { inherit name; value = {}; }))
builtins.listToAttrs
- ];
+ ] // {
+ "mail.clicks.codes".postRun = ''
+ cp -r $(pwd) /opt/mailcow-dockerized/data/assets/ssl/
+ cp -r $(pwd)/* /opt/mailcow-dockerized/data/assets/ssl/
+ '';
+ };
defaults.postRun = "cp -r $(pwd) /opt/mailcow-dockerized/data/assets/ssl/";
};
}