nix flake update

To use parsedmarc, we need the latest versions of everything (plus,
staying up-to-date has its own benefits). It seems that this update also
updates nix to a version where overlays can no longer take a functor, so
I have wrapped the frappix overlays in a function to workaround this
issue

Change-Id: Ia029232ad605783b304251c4182ec017c209c0c3
Reviewed-on: https://git.clicks.codes/c/Infra/NixFiles/+/541
Tested-by: Skyler Grey <minion@clicks.codes>
Reviewed-by: Samuel Shuert <coded@clicks.codes>
diff --git a/flake.nix b/flake.nix
index 0ca0186..87c388a 100644
--- a/flake.nix
+++ b/flake.nix
@@ -13,7 +13,7 @@
   inputs.nixpkgs-privatebin.url = "github:e1mo/nixpkgs/privatebin";
   inputs.nixpkgs-mongodb.url = "github:nixos/nixpkgs?rev=8dfad603247387df1df4826b8bea58efc5d012d8";
 
-  inputs.helpers.url = "git+https://git.clicks.codes/Clicks/NixHelpers";
+  inputs.helpers.url = "git+https://git.clicks.codes/Infra/NixHelpers";
 
   inputs.frappix.url = "github:blaggacao/frappix";
 
@@ -48,9 +48,22 @@
             inherit (nixpkgs-privatebin.legacyPackages.${system})
               privatebin pbcli;
           })
-          frappix.toolsOverlay.${system}
-          frappix.pythonOverlay.${system}
-          frappix.frappeOverlay.${system}
+          (functorBuster: frappix.toolsOverlay.${system} functorBuster)
+          (functorBuster: frappix.pythonOverlay.${system} functorBuster)
+          (functorBuster: frappix.frappeOverlay.${system} functorBuster)
+          (final: prev: {
+            python311 = prev.python311.override {
+              packageOverrides = pyFinal: pyPrev: {
+                elasticsearch = (
+                  pyPrev.elasticsearch.overrideAttrs (prevAttrs: {
+                    propagatedBuildInputs = prevAttrs.propagatedBuildInputs ++ [
+                      final.python311Packages.elastic-transport
+                    ];
+                  })
+                );
+              };
+            };
+          })
         ];
       };
       helpers = inputs.helpers.helpers { inherit pkgs nixpkgs; };