Install postgres and dendrite
diff --git a/modules/home-manager-users.nix b/modules/home-manager-users.nix
index e83e0cb..a3f450e 100644
--- a/modules/home-manager-users.nix
+++ b/modules/home-manager-users.nix
@@ -1,6 +1,6 @@
# Home manager is used separately from this deploy, but we still need to create
# user accounts in the system config
-{ pkgs, lib, ... }:
+{ base, pkgs, lib, config, ... }:
let
mkUser = username: {
isSystemUser = true;
@@ -9,7 +9,11 @@
home = "/services/${username}";
group = "clicks";
shell = pkgs.bashInteractive;
- };
+ } // (
+ if builtins.pathExists "${../services}/${username}/system.nix"
+ then import "${../services}/${username}/system.nix"
+ else { }
+ );
in
{
imports = [
@@ -26,4 +30,14 @@
(map (name: { inherit name; value = mkUser name; }))
builtins.listToAttrs
];
-}
+} // (
+ if (base != null)
+ then {
+/* users.groups = lib.mapAttrs'
+ (_: user: {
+ name = user.group;
+ value = { };
+ })
+ base.config.users.users;*/
+ } else { }
+)