Install postgres and dendrite
diff --git a/modules/scalpel.nix b/modules/scalpel.nix
new file mode 100644
index 0000000..569d2b4
--- /dev/null
+++ b/modules/scalpel.nix
@@ -0,0 +1,12 @@
+{ lib, config, ... }: let
+ cfg = config.scalpel;
+in {
+ system.activationScripts.scalpelCreateStore.text = lib.mkForce ''
+ echo "[scalpel] Ensuring existance of ${cfg.secretsDir}"
+ mkdir -p ${cfg.secretsDir}
+ grep -q "${cfg.secretsDir} ramfs" /proc/mounts || mount -t ramfs none "${cfg.secretsDir}" -o nodev,nosuid,mode=0751
+
+ echo "[scalpel] Clearing old secrets from ${cfg.secretsDir}"
+ find '${cfg.secretsDir}' -wholename '${cfg.secretsDir}' -o -prune -exec rm -rf -- {} +
+ '';
+}