nix flake update

- this includes helpers change Ie1b0edbbb126c6cd6dcd8f0b4fd0cc829ee2b00c
- this updates nixpkgs. Likely this will be the final update before 23.11
- this fixes issues encountered while updating. These were
  - missing URL for richdocumentscode
  - replace fragile gerrit oauth plugin bazel build with prebuild jar
  - remove mongodb, as it is broken
  - remove references to "nobody" group. For sops secrets, replace these with
    "root"

Change-Id: I997f6067ea58b5996c6a386e6f4bf376fc458421
diff --git a/modules/grafana.nix b/modules/grafana.nix
index 6c63f75..948d29a 100644
--- a/modules/grafana.nix
+++ b/modules/grafana.nix
@@ -51,8 +51,8 @@
 
   sops.secrets.clicks_grafana_client_secret = {
     mode = "0600";
-    owner = "root";
-    group = "nobody";
+    owner = config.users.users.root.name;
+    group = config.users.users.root.group;
     sopsFile = ../secrets/grafana.json;
     format = "json";
   };
@@ -76,7 +76,7 @@
       matchers."client_secret".secret =
         config.sops.secrets.clicks_grafana_client_secret.path;
       owner = config.users.users.grafana.name;
-      group = "nobody";
+      group = config.users.users.root.name;
       mode = "0400";
     };