fix(headscale)!: Rename 'url' to 'domain'
This better reflects the value which goes in the option by removing
confusion about if the protocol should be included
Change-Id: Ib550eb97b96999a733c07915c8738a337546ec52
Reviewed-on: https://git.clicks.codes/c/Infra/NixFiles/+/790
Reviewed-by: Samuel Shuert <coded@clicks.codes>
Tested-by: Skyler Grey <minion@clicks.codes>
diff --git a/modules/nixos/clicks/services/headscale/default.nix b/modules/nixos/clicks/services/headscale/default.nix
index 1e1b0d8..b540acb 100644
--- a/modules/nixos/clicks/services/headscale/default.nix
+++ b/modules/nixos/clicks/services/headscale/default.nix
@@ -14,9 +14,9 @@
{
options.clicks.services.headscale = {
enable = lib.mkEnableOption "The headscale control server for tailscale";
- url = lib.mkOption {
+ domain = lib.mkOption {
type = lib.types.str;
- description = "The url users should connect to to register a new device";
+ description = "The domain of the url users should connect to to register a new device";
};
addr = lib.mkOption {
type = lib.types.str;
@@ -89,7 +89,7 @@
settings.db_name = "headscale";
settings.db_host = lib.clicks.constants.hosts.standard;
- settings.server_url = "https://${cfg.url}";
+ settings.server_url = "https://${cfg.domain}";
settings.ip_prefixes = "100.64.0.0/10";
@@ -103,9 +103,9 @@
"1.1.1.1"
"1.0.0.1"
];
- domains = [ cfg.url ];
+ domains = [ cfg.domain ];
override_local_dns = true;
- base_domain = cfg.url;
+ base_domain = cfg.domain;
};
settings.oidc = lib.mkIf cfg.oidc.enable {