revert: fix(non-clicks): Re-export dependencies
In change I433d34395b0449de17af2dea2a8a3138c1ff6dba, we moved to
re-export dependencies in a hope that it would let people easily import
our modules and avoid evaluation errors
Unfortunately, if someone already uses our dependency, importing again
doesn't only import a single copy, as would happen in languages like
Python, rather it imports it a second time, and fails due to duplicate
declarations!
This makes containing our dependencies in our exports untenable
Change-Id: I4e5d15e1f436e4140bcb27e4ed15542b4f5812af
Reviewed-on: https://git.clicks.codes/c/Infra/NixFiles/+/809
Reviewed-by: Skyler Grey <minion@clicks.codes>
Tested-by: Skyler Grey <minion@clicks.codes>
diff --git a/flake.nix b/flake.nix
index ed9c9af..5500287 100644
--- a/flake.nix
+++ b/flake.nix
@@ -61,12 +61,6 @@
namespace = "clicks";
};
}).snowfall.internal.system-lib;
-
- nixosModuleDependencies = {
- agenix = inputs.agenix.nixosModules.default;
- agenix-rekey = inputs.agenix-rekey.nixosModules.default;
- impermanence = inputs.impermanence.nixosModules.impermanence;
- };
in
lib.mkFlake {
overlays = [
@@ -74,12 +68,15 @@
];
systems.modules.nixos = [
+ inputs.agenix.nixosModules.default
+ inputs.agenix-rekey.nixosModules.default
+ inputs.impermanence.nixosModules.impermanence
{
config.clicks.defaults.enable = true;
# set defaults that are clicks-specific, such as our backups module
# being enabled...
}
- ] ++ (lib.attrsets.attrValues nixosModuleDependencies);
+ ];
deploy = lib.clicks.deploy.mkDeploy {
inherit (inputs) self;
@@ -96,21 +93,6 @@
nodes = inputs.self.nixosConfigurations;
};
- # We need to re-export dependencies, as this is *invalid* unless
- # environment.persistence is defined, so importing all our modules will
- # otherwise break evaluation
- #
- # config = lib.mkIf false {
- # environment.persistence = {
- # ...
- # };
- # };
- #
- modules.nixos = lib.attrsets.mapAttrs' (name: value: {
- name = "dependency/${name}";
- inherit value;
- }) nixosModuleDependencies;
-
outputs-builder = channels: {
specs = let
nixFiles = lib.snowfall.fs.get-nix-files-recursive ./.;