Move gerrit oauth to flake input
Previously, we used fetchurl to get the gerrit oauth plugin. This had
the disadvantage that auto-updates did not work, and additionally did
not have the advantage that the config would continue to work with old
versions as the artifact URL was removed when a new version was built.
This will allow us to update gerrit oauth with 'nix flake lock' and will
break no more commonly than before
Change-Id: I6d82752c380aea6301c26de169b01480d260a830
Reviewed-on: https://git.clicks.codes/c/Clicks/NixFiles/+/201
Tested-by: Skyler Grey <minion@clicks.codes>
Reviewed-by: Samuel Shuert <coded@clicks.codes>
diff --git a/flake.nix b/flake.nix
index 482f247..722899c 100644
--- a/flake.nix
+++ b/flake.nix
@@ -23,6 +23,11 @@
inputs.scalpel.inputs.nixpkgs.follows = "nixpkgs";
inputs.scalpel.inputs.sops-nix.follows = "sops-nix";
+ inputs.gerrit-oauth = {
+ url = "https://gerrit-ci.gerritforge.com/job/plugin-oauth-bazel-master-master/lastBuild/artifact/bazel-bin/plugins/oauth/oauth.jar";
+ flake = false;
+ };
+
outputs = { self, nixpkgs, deploy-rs, home-manager, sops-nix, scalpel
, nixpkgs-privatebin, ... }@inputs:
let