muliple(teal): Update teal

feat: Add a.starrysky.blog
feat: re-key keys with shorthairNanoResident age key
chore: update packages
fix: redo headscale options
Change-Id: I27cab9abc4622f0a69811e35d4e0eb87af29b42b
Reviewed-on: https://git.clicks.codes/c/Infra/NixFiles/+/981
Reviewed-by: Skyler Grey <minion@clicks.codes>
Tested-by: Skyler Grey <minion@clicks.codes>
diff --git a/modules/nixos/clicks/services/postgres/default.nix b/modules/nixos/clicks/services/postgres/default.nix
index 0f6b71f..836bf71 100644
--- a/modules/nixos/clicks/services/postgres/default.nix
+++ b/modules/nixos/clicks/services/postgres/default.nix
@@ -2,13 +2,14 @@
 #
 # SPDX-License-Identifier: GPL-3.0-only
 
-{ lib, config, ... }:
+{ lib, config, pkgs, ... }:
 let
   cfg = config.clicks.services.postgres;
 in
 {
   options.clicks.services.postgres = {
     enable = lib.mkEnableOption "Postgresql DB";
+    latest = lib.mkEnableOption "Use pinned PG version, otherwise default to 15.10";
 
     databases = lib.mkOption {
       type = lib.types.attrsOf lib.types.str;
@@ -34,6 +35,7 @@
     lib.mkIf cfg.enable {
       services.postgresql = {
         enable = true;
+        package = if cfg.latest then pkgs.postgresql else pkgs.postgresql_15;
 
         settings = {
           listen_addresses = lib.mkForce lib.clicks.constants.hosts.standard;