feat(storage): add impermanence

We'll setup impermanence for a1d1 based on some RAIDed together hard
drives we have. In doing so, we'll gain the ability to keep some
important data persistent while losing everything else.

This is also useful when looking for what to backup.

Change-Id: I51a9dfcaea46a4a21e601615ddd7288c91effa9e
Reviewed-on: https://git.clicks.codes/c/Infra/NixFiles/+/724
Tested-by: Samuel Shuert <coded@clicks.codes>
Reviewed-by: Samuel Shuert <coded@clicks.codes>
diff --git a/systems/x86_64-linux/a1d1/default.nix b/systems/x86_64-linux/a1d1/default.nix
index 4f7e821..cd71bbf 100644
--- a/systems/x86_64-linux/a1d1/default.nix
+++ b/systems/x86_64-linux/a1d1/default.nix
@@ -32,7 +32,10 @@
       raid.enable = true;
       impermanence = {
         enable = true;
-        device = "/dev/disk/by-uuid/ab5c2f52-a737-4b29-a505-e3d0b9d0714c";
+        devices = {
+          root = "/dev/disk/by-uuid/ab5c2f52-a737-4b29-a505-e3d0b9d0714c";
+          persist = "/dev/md/a1d1:persist";
+        };
       };
     };
   };