feat: Add nginx module

Change-Id: I34fbb926c4b7eab344c1c14de4e4b5f82c6c30eb
Reviewed-on: https://git.clicks.codes/c/Infra/NixFiles/+/785
Reviewed-by: Samuel Shuert <coded@clicks.codes>
Tested-by: Skyler Grey <minion@clicks.codes>
diff --git a/overlays/tailscale-nginx-auth/default.nix b/overlays/tailscale-nginx-auth/default.nix
new file mode 100644
index 0000000..320c936
--- /dev/null
+++ b/overlays/tailscale-nginx-auth/default.nix
@@ -0,0 +1,11 @@
+# SPDX-FileCopyrightText: 2024 Clicks Codes
+#
+# SPDX-License-Identifier: GPL-3.0-only
+
+{...}: final: prev: {
+  tailscale-nginx-auth = prev.tailscale-nginx-auth.overrideAttrs (prevAttrs: {
+    patches = (prevAttrs.patches or []) ++ [
+      ./fix-headscale-computedname.patch
+    ];
+  });
+}