feat(teal): beancount: minion: update config

There are various plugins I would like to have for settling up some
expenses from a holiday. Additionally, there are some sensible settings
that I'd like to nail down in nix config.

Change-Id: I344c13e14be5bbdb74118ab162cda2fbc3e7e7fc
Reviewed-on: https://git.clicks.codes/c/Infra/NixFiles/+/861
Reviewed-by: Skyler Grey <minion@clicks.codes>
Tested-by: Skyler Grey <minion@clicks.codes>
diff --git a/packages/beancount-beancount_plugin_utils/default.nix b/packages/beancount-beancount_plugin_utils/default.nix
new file mode 100644
index 0000000..0a89a33
--- /dev/null
+++ b/packages/beancount-beancount_plugin_utils/default.nix
@@ -0,0 +1,34 @@
+{ lib
+, python3
+}: let
+  pname = "beancount_plugin_utils";
+  version = "0.0.4";
+in python3.pkgs.buildPythonApplication {
+  inherit pname version;
+
+  src = python3.pkgs.fetchPypi {
+    inherit pname version;
+    sha256 = "sha256-6deB3v3zzPQkXb8haEOP4KnksKax04SZ+YBLagpad4o=";
+  };
+
+  format = "pyproject";
+
+  propagatedBuildInputs = [
+    python3.pkgs.beancount
+  ];
+
+  buildInputs = [
+    python3.pkgs.setuptools
+    python3.pkgs.pdm-pep517
+  ];
+
+  meta = {
+    homepage = "https://github.com/Akuukis/beancount_plugin_utils";
+    description = ''Utils for beancount plugin writers - BeancountError, mark, metaset, etc.
+
+    Not ready for public use, but used by various Akuukis plugins.
+    Appears unmaintained'';
+    license = lib.licenses.agpl3Only;
+    maintainers = [ lib.maintainers.minion3665 ];
+  };
+}