feat(teal): beancount: minion: update config

There are various plugins I would like to have for settling up some
expenses from a holiday. Additionally, there are some sensible settings
that I'd like to nail down in nix config.

Change-Id: I344c13e14be5bbdb74118ab162cda2fbc3e7e7fc
Reviewed-on: https://git.clicks.codes/c/Infra/NixFiles/+/861
Reviewed-by: Skyler Grey <minion@clicks.codes>
Tested-by: Skyler Grey <minion@clicks.codes>
diff --git a/packages/beancount-beancount_share/default.nix b/packages/beancount-beancount_share/default.nix
new file mode 100644
index 0000000..21c5261
--- /dev/null
+++ b/packages/beancount-beancount_share/default.nix
@@ -0,0 +1,33 @@
+{ lib
+, python3
+, clicks
+}: let
+  pname = "beancount_share";
+  version = "0.1.10";
+in python3.pkgs.buildPythonApplication {
+  inherit pname version;
+
+  src = python3.pkgs.fetchPypi {
+    inherit pname version;
+    sha256 = "sha256-fnbdzijt/kCi4sUxCf2IPkpCjdwz9cZyCOJyQTAKkaY=";
+  };
+
+  format = "pyproject";
+
+  propagatedBuildInputs = [
+    python3.pkgs.beancount
+    clicks.beancount-beancount_plugin_utils
+  ];
+
+  buildInputs = [
+    python3.pkgs.setuptools
+    python3.pkgs.pdm-pep517
+  ];
+
+  meta = {
+    homepage = "https://github.com/Akuukis/beancount_share";
+    description = "A beancount plugin to share expenses with external partners within one ledger.";
+    license = lib.licenses.agpl3Only;
+    maintainers = [ lib.maintainers.minion3665 ];
+  };
+}