Enable the firewall and set some permitted ports
diff --git a/default/configuration.nix b/default/configuration.nix
index d89bcba..3b8888e 100644
--- a/default/configuration.nix
+++ b/default/configuration.nix
@@ -131,13 +131,13 @@
 
   # Enable the OpenSSH daemon.
   services.openssh.enable = true;
-  services.openssh.settings.passwordAuthentication = false;
+  services.openssh.passwordAuthentication = false;
 
   # Open ports in the firewall.
-  # networking.firewall.allowedTCPPorts = [ ... ];
+  networking.firewall.allowedTCPPorts = [ 22 80 443 25 465 587 110 995 143 993 ];
   # networking.firewall.allowedUDPPorts = [ ... ];
   # Or disable the firewall altogether.
-  networking.firewall.enable = false;
+  networking.firewall.enable = true;
   networking.hostName = "Clicks";
   # Copy the NixOS configuration file and link it from the resulting system
   # (/run/current-system/configuration.nix). This is useful in case you