Setup a wiki.js instance for TransPlace
Similarly to the redis instance, TransPlace is rather annoying to run
services on. Therefore, I have offered to run this on nix until such a
time as Cleo figures out how to set this up on pterodactyl
Change-Id: Iceff9c46e34201968f8e7b097267641499417b57
Reviewed-on: https://git.clicks.codes/c/Infra/NixFiles/+/632
Reviewed-by: Samuel Shuert <coded@clicks.codes>
Tested-by: Skyler Grey <minion@clicks.codes>
diff --git a/modules/common/wikijs.nix b/modules/common/wikijs.nix
new file mode 100644
index 0000000..506de26
--- /dev/null
+++ b/modules/common/wikijs.nix
@@ -0,0 +1,26 @@
+{ config, ... }: {
+ services.wiki-js = {
+ enable = true;
+
+ settings = {
+ bindIP = "127.0.0.255";
+ port = 1035;
+
+ db = {
+ host = "standard";
+ user = "wiki";
+ pass = "$(DB_PASS)";
+ };
+ };
+
+ environmentFile = config.sops.secrets.wikijs__env_bin.path;
+ };
+
+ sops.secrets.wikijs__env_bin = {
+ mode = "0600";
+ owner = config.users.users.root.name;
+ group = config.users.users.root.group;
+ sopsFile = ../../secrets/wikijs.env.bin;
+ format = "binary";
+ };
+}