feat(storage): add raid

We'll be using software raid for our impermanence persist drives on a1d1,
so we need to add a way to enable it

Change-Id: I1f2946b37e5950fe82b906df4ba191097c0d2abb
Reviewed-on: https://git.clicks.codes/c/Infra/NixFiles/+/723
Tested-by: Samuel Shuert <coded@clicks.codes>
Reviewed-by: Samuel Shuert <coded@clicks.codes>
diff --git a/systems/x86_64-linux/a1d1/default.nix b/systems/x86_64-linux/a1d1/default.nix
index 3add29d..4f7e821 100644
--- a/systems/x86_64-linux/a1d1/default.nix
+++ b/systems/x86_64-linux/a1d1/default.nix
@@ -29,6 +29,7 @@
     };
 
     storage = {
+      raid.enable = true;
       impermanence = {
         enable = true;
         device = "/dev/disk/by-uuid/ab5c2f52-a737-4b29-a505-e3d0b9d0714c";