Move all flakes into modules/ and sep't, create deploy script for a1d2
Change-Id: Ie4d50fb8f16da193195beb139922a366b72b0b0a
diff --git a/modules/common/mongodb.nix b/modules/common/mongodb.nix
new file mode 100644
index 0000000..0c4ebc5
--- /dev/null
+++ b/modules/common/mongodb.nix
@@ -0,0 +1,16 @@
+{ config, nixpkgs-mongodb, system, ... }: let
+ pkgs = import nixpkgs-mongodb {
+ config.allowUnfree = true;
+ inherit system;
+ };
+in {
+ environment.systemPackages = [ pkgs.mongosh pkgs.mongodb-tools ];
+ services.mongodb.enable = true;
+ services.mongodb.enableAuth = true;
+ services.mongodb.bind_ip = "0.0.0.0";
+ services.mongodb.initialRootPassword = "changeme";
+ services.mongodb.package = pkgs.mongodb-6_0;
+
+ networking.firewall.extraCommands =
+ "iptables -A INPUT -s 192.168.0.4 -p tcp --dport 27017 -j ACCEPT";
+}