feat(fava): Specify default-file in options

I made a patch for fava, open at https://github.com/beancount/fava/pull/1833,
which makes default files able to be specified as an argument rather
than by placing the default-file directive in the default file. This is
a lot cleaner for us, as this was the only line that we needed to inject
into our newly-created ledgers

Additionally, this patch makes default files be the target for added
entries, which allows us to use the "+" button and will also be required
for importers, both of which previously attempted to insert entries in
the read-only settings file

Change-Id: I49dd803941d8c855eeecb274bd4973a42283c17f
Reviewed-on: https://git.clicks.codes/c/Infra/NixFiles/+/804
Reviewed-by: Skyler Grey <minion@clicks.codes>
Tested-by: Skyler Grey <minion@clicks.codes>
diff --git a/overlays/fava/default.nix b/overlays/fava/default.nix
index 1a9d549..a847886 100644
--- a/overlays/fava/default.nix
+++ b/overlays/fava/default.nix
@@ -19,6 +19,7 @@
 
     patches = (prevAttrs.patches or []) ++ [
       ./1833-respect-ordering.patch
+      ./1838-default-file-improvements.patch
     ];
   });
 }