Change the default config so gerrit rebases

We don't want merge commits, and we would like gerrit to rebase so that we get
trailers like the Gerrit-Reviewed-On trailer.

Here are the advantages of REBASE_ALWAYS:
- Adding trailers (unlike merges or fast forwards)
- Cares about dependencies (unlike cherry pick)
- Does not introduce merge commits (unlike merges)
- Does not require manual rebasing the majority of the time (unlike fast
  forwards)

Change-Id: If94f39c85be48f7fb3aa2138ae60fc3a5f9d4834
diff --git a/modules/gerrit.nix b/modules/gerrit.nix
index 6c0749c..7c42545 100644
--- a/modules/gerrit.nix
+++ b/modules/gerrit.nix
@@ -81,6 +81,7 @@
         startTime = "Sun 00:00";
         interval = "1 week";
       };
+      repository."*".defaultSubmitType = "REBASE_ALWAYS";
       gerrit = {
         basePath = "/var/lib/gerrit/repos";
         defaultBranch = "refs/heads/main";