Format with nixfmt
Change-Id: If9839d2c3308538ac8f3e166b69675d3b40bd7d9
diff --git a/modules/ecryptfs.nix b/modules/ecryptfs.nix
index c54c93e..dd85ca9 100644
--- a/modules/ecryptfs.nix
+++ b/modules/ecryptfs.nix
@@ -1,7 +1,7 @@
{ pkgs, ... }: {
- environment.systemPackages = with pkgs; let
- unlock-database-script = writeScriptBin "unlock-database-encryption"
- ''
+ environment.systemPackages = with pkgs;
+ let
+ unlock-database-script = writeScriptBin "unlock-database-encryption" ''
if [ $UID -ne 0 ]; then
echo "unlock-database-encryption must be run as root"
exit 1
@@ -12,10 +12,5 @@
mount -i -t ecryptfs /var/db/.mongodb-encrypted/ /var/db/mongodb -o ecryptfs_sig=$ECRYPTFS_SIG,ecryptfs_fnek_sig=$ECRYPTFS_SIG,ecryptfs_cipher=aes,ecryptfs_key_bytes=32,ecryptfs_unlink_sigs
'';
- in
- [
- ecryptfs
- keyutils
- unlock-database-script
- ];
+ in [ ecryptfs keyutils unlock-database-script ];
}