Format with nixfmt
Change-Id: If9839d2c3308538ac8f3e166b69675d3b40bd7d9
diff --git a/modules/nginx-routes.nix b/modules/nginx-routes.nix
index 918d6dd..889a17c 100644
--- a/modules/nginx-routes.nix
+++ b/modules/nginx-routes.nix
@@ -6,7 +6,8 @@
(Host "testing.coded.codes" (ReverseProxy "SamuelDesktop.local:3000"))
(Hosts [ "kavita.coded.codes" "reading.coded.codes" ]
(ReverseProxy "localhost:5000"))
- (Host "www.clicks.codes" (RedirectPermanent "https://clicks.codes$request_uri"))
+ (Host "www.clicks.codes"
+ (RedirectPermanent "https://clicks.codes$request_uri"))
(Host "clicks.codes" (ReverseProxy "127.0.0.1:3000"))
(Host "passwords.clicks.codes" (ReverseProxy "localhost:8452"))
(Host "login.clicks.codes" (ReverseProxy "localhost:9083"))
@@ -37,37 +38,39 @@
"smtp.clicks.codes"
"smtp.hopescaramels.com"
] (ReverseProxy "localhost:1080"))
- (Hosts [
- "mail.clicks.codes"
- "mail.coded.codes"
- "mail.hopescaramels.com"
- ] (ReverseProxy "localhost:1080"))
- (Host "matrix.coded.codes" (Directory "${builtins.toString (pkgs.schildichat-web.override {
- conf = {
- default_server_config = lib.pipe ./nginx/coded.codes/.well-known/matrix [
- builtins.readFile
- builtins.fromJSON
- ];
- features = {
- feature_report_to_moderators = true;
- feature_latex_maths = true;
- feature_pinning = true;
- feature_mjolnir = true;
- feature_presence_in_room_list = true;
- feature_custom_themes = true;
- feature_dehydration = true;
+ (Hosts [ "mail.clicks.codes" "mail.coded.codes" "mail.hopescaramels.com" ]
+ (ReverseProxy "localhost:1080"))
+ (Host "matrix.coded.codes" (Directory "${builtins.toString
+ (pkgs.schildichat-web.override {
+ conf = {
+ default_server_config =
+ lib.pipe ./nginx/coded.codes/.well-known/matrix [
+ builtins.readFile
+ builtins.fromJSON
+ ];
+ features = {
+ feature_report_to_moderators = true;
+ feature_latex_maths = true;
+ feature_pinning = true;
+ feature_mjolnir = true;
+ feature_presence_in_room_list = true;
+ feature_custom_themes = true;
+ feature_dehydration = true;
+ };
+ setting_defaults = { "fallbackICEServerAllowed" = true; };
+ default_theme = "dark";
+ permalink_prefix = "https://matrix.coded.codes";
+ disable_guests = true;
+ disable_3pid_login = true;
};
- setting_defaults = { "fallbackICEServerAllowed" = true; };
- default_theme = "dark";
- permalink_prefix = "https://matrix.coded.codes";
- disable_guests = true;
- disable_3pid_login = true;
- };
- })}"))
- (Host "api.clicks.codes" (Path "/nucleus/" (ReverseProxy "localhost:10000")))
- (Host "api.coded.codes" (Path "/nucleus/" (ReverseProxy "SamuelDesktop.local:10000")))
+ })}"))
+ (Host "api.clicks.codes"
+ (Path "/nucleus/" (ReverseProxy "localhost:10000")))
+ (Host "api.coded.codes"
+ (Path "/nucleus/" (ReverseProxy "SamuelDesktop.local:10000")))
(Host "coded.codes" (Compose [
- (Path "/.well-known/matrix/" (File ./nginx/coded.codes/.well-known/matrix))
+ (Path "/.well-known/matrix/"
+ (File ./nginx/coded.codes/.well-known/matrix))
(Redirect "https://clicks.codes$request_uri")
]))
(Host "matrix-backend.coded.codes" (Compose [
@@ -88,12 +91,12 @@
])
];
clicks.nginx.streams = with helpers.nginx; [
- (Stream 143 "localhost:1143" "tcp") #imap
- (Stream 993 "localhost:1993" "tcp") #imap
- (Stream 110 "localhost:1110" "tcp") #pop3
- (Stream 995 "localhost:1995" "tcp") #pop3
- (Stream 25 "localhost:1025" "tcp") #smtp
- (Stream 465 "localhost:1465" "tcp") #smtp
- (Stream 587 "localhost:1587" "tcp") #smtp
+ (Stream 143 "localhost:1143" "tcp") # imap
+ (Stream 993 "localhost:1993" "tcp") # imap
+ (Stream 110 "localhost:1110" "tcp") # pop3
+ (Stream 995 "localhost:1995" "tcp") # pop3
+ (Stream 25 "localhost:1025" "tcp") # smtp
+ (Stream 465 "localhost:1465" "tcp") # smtp
+ (Stream 587 "localhost:1587" "tcp") # smtp
];
}