Format with nixfmt
Change-Id: If9839d2c3308538ac8f3e166b69675d3b40bd7d9
diff --git a/modules/privatebin.nix b/modules/privatebin.nix
index 17a1556..25e29fd 100644
--- a/modules/privatebin.nix
+++ b/modules/privatebin.nix
@@ -1,6 +1,5 @@
{ config, lib, base, ... }:
-lib.recursiveUpdate
-{
+lib.recursiveUpdate {
services.privatebin = {
enable = true;
settings = {
@@ -14,8 +13,10 @@
syntaxhighlightingtheme = "sons-of-obsidian";
template = "bootstrap-dark";
- info = ''Powered by <a href="https://privatebin.info/">PrivateBin</a>. Provided as a service free-of-charge by Clicks. Come chat with us <a href="https://matrix.to/#/#global:coded.codes"> on Matrix</a>'';
- notice = "This service has no guarantee of uptime, and pastes are not backed up. If you need somewhere to host the last words of your wise old grandfather for time immemorial this is not the place.";
+ info = ''
+ Powered by <a href="https://privatebin.info/">PrivateBin</a>. Provided as a service free-of-charge by Clicks. Come chat with us <a href="https://matrix.to/#/#global:coded.codes"> on Matrix</a>'';
+ notice =
+ "This service has no guarantee of uptime, and pastes are not backed up. If you need somewhere to host the last words of your wise old grandfather for time immemorial this is not the place.";
langaugeselection = true;
};
@@ -28,7 +29,8 @@
expire.default = "1month";
expire_options = {
- "5min" = 300; # looks bonkers, but I'm trying to keep the list ordered while also keeping the privatebin label formatter happy
+ "5min" =
+ 300; # looks bonkers, but I'm trying to keep the list ordered while also keeping the privatebin label formatter happy
"10min" = 600;
"1hour" = 3600;
"1day" = 86400;
@@ -43,7 +45,8 @@
};
traffic = {
- exempted = "10.0.0.0/8,127.0.0.0/8,169.254.0.0/16,172.16.0.0/12,192.168.0.0/16";
+ exempted =
+ "10.0.0.0/8,127.0.0.0/8,169.254.0.0/16,172.16.0.0/12,192.168.0.0/16";
};
model.class = "Database";
@@ -55,23 +58,19 @@
};
};
};
-}
-(
- if base != null
- then {
- services.privatebin.environmentFiles = [
- config.scalpel.trafos."privatebin.env".destination
- ];
+} (if base != null then {
+ services.privatebin.environmentFiles =
+ [ config.scalpel.trafos."privatebin.env".destination ];
- scalpel.trafos."privatebin.env" = {
- source = builtins.toFile "privatebin.env" ''
- PRIVATEBIN_DB_PASSWORD=!!privatebin_db_password!!
- '';
- matchers."privatebin_db_password".secret =
- config.sops.secrets.clicks_privatebin_db_password.path;
- owner = config.users.users.privatebin.name;
- group = config.users.users.privatebin.group;
- mode = "0400";
- };
- }
- else {})
+ scalpel.trafos."privatebin.env" = {
+ source = builtins.toFile "privatebin.env" ''
+ PRIVATEBIN_DB_PASSWORD=!!privatebin_db_password!!
+ '';
+ matchers."privatebin_db_password".secret =
+ config.sops.secrets.clicks_privatebin_db_password.path;
+ owner = config.users.users.privatebin.name;
+ group = config.users.users.privatebin.group;
+ mode = "0400";
+ };
+} else
+ { })