Format with nixfmt
Change-Id: If9839d2c3308538ac8f3e166b69675d3b40bd7d9
diff --git a/services/clicksforms/discordpy.nix b/services/clicksforms/discordpy.nix
index 83aed0f..11985db 100644
--- a/services/clicksforms/discordpy.nix
+++ b/services/clicksforms/discordpy.nix
@@ -1,13 +1,5 @@
-{ lib
-, aiohttp
-, buildPythonPackage
-, fetchFromGitHub
-, libopus
-, pynacl
-, pythonOlder
-, withVoice ? true
-, ffmpeg
-}:
+{ lib, aiohttp, buildPythonPackage, fetchFromGitHub, libopus, pynacl
+, pythonOlder, withVoice ? true, ffmpeg }:
buildPythonPackage rec {
pname = "discord.py";
@@ -23,13 +15,8 @@
hash = "sha256-Rh3gijm67LVyOaliP7w3YwKviKydnxXvu4snNrM5H1c=";
};
- propagatedBuildInputs = [
- aiohttp
- ] ++ lib.optionals withVoice [
- libopus
- pynacl
- ffmpeg
- ];
+ propagatedBuildInputs = [ aiohttp ]
+ ++ lib.optionals withVoice [ libopus pynacl ffmpeg ];
patchPhase = ''
substituteInPlace "discord/opus.py" \
@@ -56,7 +43,8 @@
meta = with lib; {
description = "Python wrapper for the Discord API";
homepage = "https://discordpy.rtfd.org/";
- changelog = "https://github.com/Rapptz/discord.py/blob/v${version}/docs/whats_new.rst";
+ changelog =
+ "https://github.com/Rapptz/discord.py/blob/v${version}/docs/whats_new.rst";
license = licenses.mit;
maintainers = with maintainers; [ minion3665 ];
};