Skyler Grey | 1e2187f | 2023-03-03 22:45:10 +0000 | [diff] [blame] | 1 | # Do not modify this file! It was generated by ‘nixos-generate-config’ |
| 2 | # and may be overwritten by future invocations. Please make changes |
| 3 | # to /etc/nixos/configuration.nix instead. |
| 4 | { config, lib, pkgs, ... }: |
| 5 | |
| 6 | { |
| 7 | boot.initrd.availableKernelModules = [ "nvme" "xhci_pci" "ahci" "usbhid" "sd_mod" ]; |
| 8 | boot.initrd.kernelModules = [ ]; |
| 9 | boot.kernelModules = [ "kvm-amd" ]; |
| 10 | boot.extraModulePackages = [ ]; |
| 11 | |
| 12 | fileSystems."/" = |
| 13 | { device = "/dev/disk/by-uuid/33e79acf-16a4-4263-be79-792c9432568c"; |
| 14 | fsType = "ext4"; |
| 15 | }; |
| 16 | |
| 17 | fileSystems."/boot" = |
| 18 | { device = "/dev/disk/by-uuid/4EB3-743A"; |
| 19 | fsType = "vfat"; |
| 20 | }; |
| 21 | |
| 22 | swapDevices = |
| 23 | [ { device = "/dev/disk/by-uuid/3f3ddaa2-80c8-4915-83fe-fcec42bb877c"; } |
| 24 | ]; |
| 25 | |
| 26 | # Enables DHCP on each ethernet and wireless interface. In case of scripted networking |
| 27 | # (the default) this is the recommended approach. When using systemd-networkd it's |
| 28 | # still possible to use this option, but it's recommended to use it in conjunction |
| 29 | # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`. |
| 30 | networking.useDHCP = lib.mkDefault true; |
| 31 | # networking.interfaces.enp5s0.useDHCP = lib.mkDefault true; |
| 32 | |
| 33 | nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux"; |
| 34 | hardware.cpu.amd.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware; |
| 35 | } |