blob: c23c68f2142d7261ca506fe60128e3768953436a [file] [log] [blame]
Skyler Grey1e2187f2023-03-03 22:45:10 +00001# Edit this configuration file to define what should be installed on
2# your system. Help is available in the configuration.nix(5) man page
3# and in the NixOS manual (accessible by running ‘nixos-help’).
4
5{ config, pkgs, lib, ... }:
6
7{
8 # Use the GRUB 2 boot loader.
9 boot.loader.systemd-boot.enable = true;
10 # boot.loader.grub.efiSupport = true;
11 # boot.loader.grub.efiInstallAsRemovable = true;
12 # boot.loader.efi.efiSysMountPoint = "/boot/efi";
13 # Define on which hard drive you want to install Grub.
14 # boot.loader.grub.device = "/dev/sda"; # or "nodev" for efi only
15
16 # networking.hostName = "nixos"; # Define your hostname.
17 # Pick only one of the below networking options.
18 # networking.wireless.enable = true; # Enables wireless support via wpa_supplicant.
19 # networking.networkmanager.enable = true; # Easiest to use and most distros use this by default.
20
21 # Set your time zone.
22 time.timeZone = "America/New_York";
23
24 # Configure network proxy if necessary
25 # networking.proxy.default = "http://user:password@proxy:port/";
26 # networking.proxy.noProxy = "127.0.0.1,localhost,internal.domain";
27
28 # Select internationalisation properties.
29 # i18n.defaultLocale = "en_US.UTF-8";
30 # console = {
31 # font = "Lat2-Terminus16";
32 # keyMap = "us";
33 # useXkbConfig = true; # use xkbOptions in tty.
34 # };
35
36 # Enable the X11 windowing system.
37 # services.xserver.enable = true;
38
39
40
41
42 # Configure keymap in X11
43 # services.xserver.layout = "us";
44 # services.xserver.xkbOptions = {
45 # "eurosign:e";
46 # "caps:escape" # map caps to escape.
47 # };
48
49 # Enable CUPS to print documents.
50 # services.printing.enable = true;
51
52 # Enable sound.
53 # sound.enable = true;
54 # hardware.pulseaudio.enable = true;
55
56 # Enable touchpad support (enabled default in most desktopManager).
57 # services.xserver.libinput.enable = true;
58
59 # Define a user account. Don't forget to set a password with ‘passwd’.
60 # users.users.alice = {
61 # isNormalUser = true;
62 # extraGroups = [ "wheel" ]; # Enable ‘sudo’ for the user.
63 # packages = with pkgs; [
64 # firefox
65 # thunderbird
66 # ];
67 # };
68 users.users.minion = {
69 isNormalUser = true;
70 extraGroups = [ "wheel" ];
71
72 openssh.authorizedKeys.keys = [
73 "ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABgQDNCOdHSYGKQj8QMQKuWsnTUCGpKNwQa+/15JVD7kxO4VxI0mavpoB6EIwVF881s2DYqRNv2UQIKbw/tZ8qnTbk8HvzvHBjuJE9okAfelphkiH60mM+FzRZrUaDFLKzTBy1fBAk1O35vNaXJS3qDdr2wQOU9D10Ulvq1RBRSVe4uWbZJUWbac/zq2ghRfcHEavhGVIqI7JRcBy8P721bFULs5lxEUMZM2MBavg2wvbFc41CXZSAmK3M+wS2WPdSA8GxbiMgcPhiArRfqJbO/v3NUGIHQnTRK3kEpblVLz9ULpTo0Kl4pcTgIGI0S3zSJIV2VXERnzkjEgNn8gjDVBCZEXyFlGlPNV1DBd+NZwcqfAXsUHGkOs+GPGm93QVsbPoqZ49N5BJg1SZCE7KWfQAnkWE/ki7Z7+BJAWbZsoc7KSz7bvy5jr6yfIzwmy4mAgiVZFfCDRI3S3oEbhqW8TWZatEPSjMgDLsh3AgYdzjYQ1p6IM91wvD+XxB0/8+LaL0= minion@python"
74 ];
75 };
76 users.users.coded = {
77 isNormalUser = true;
78 extraGroups = [ "wheel" ];
79 shell = pkgs.zsh;
80
81 openssh.authorizedKeys.keys = [
82 "ssh-rsa AAAAB3NzaC1yc2EAAAADAQABAAABgQCZGErwcw5YUlJS9tAfIYOSqkiuDRZZRTJjMlrDaAiNwTjqUML/Lrcau/1KA6a0+sXCM8DhQ1e0qhh2Qxmh/kxZWO6XMVK2EB7ELPNojqFI16T8Bbhq2t7yVAqbPUhXLQ4xKGvWMCPWOCo/dY72P9yu7kkMV0kTW3nq25+8nvqIvvuQOlOUx1uyR7qEfO706O86wjVTIuwfZKyzMDIC909vyg0xS+SfFlD7MkBuGzevQnOAV3U6tyafg6XW4PaJuDLyGXwpKz6asY08F7gRL/7/GhlMB09nfFfT4sZggmqPdGAtxwsFuwHPjNSlktHz5nlHtpS0LjefR9mWiGIhw5Hw1z33lxP0rfmiEU9J7kFcXv9B8QAWFwWfNEZfeqB7h7DJruo+QRStGeDz4SwRG3GR+DB4iNJLt7n0ALkVFJpOpskeo8TV4+Fwok+hYs2GsvdEmh9Cj7dC/9CyRhJeam9iLIi/iVGZhXEE3tIiqEktZPjiK7JwQyr97zhGJ7Rj4oE= samue@SamuelDesktop"
83 ];
84 };
Skyler Grey62ade0b2023-03-04 11:58:20 +000085 users.users.pinea = {
86 isNormalUser = true;
87 extraGroups = [ "wheel" ];
88 shell = pkgs.zsh;
89
90 openssh.authorizedKeys.keys = [
Skyler Grey335bd902023-03-05 12:34:12 +000091 "sk-ssh-ed25519@openssh.com AAAAGnNrLXNzaC1lZDI1NTE5QG9wZW5zc2guY29tAAAAIFXa8ow7H8XpTrwYI+oSgLFfb6YNZanwv/QCKvEKiERSAAAABHNzaDo= pineapplefan@Pineapplefan"
Skyler Grey1d6ed722023-03-08 00:14:12 +000092 "ecdsa-sha2-nistp256 AAAAE2VjZHNhLXNoYTItbmlzdHAyNTYAAAAIbmlzdHAyNTYAAABBBAJNFMUYiEepGrIAbUM+Hlw/OuGWc8CNQsYlJ7519RVmeu+/vqEQbhchySTelibD19YqsZ7ICfYxAeQzOqHdXfs="
Skyler Grey62ade0b2023-03-04 11:58:20 +000093 ];
94 };
Skyler Grey1e2187f2023-03-03 22:45:10 +000095 users.users.nucleus = {
96 isSystemUser = true;
97 createHome = true;
Skyler Grey4f3e6062023-03-04 01:29:29 +000098 home = "/services/nucleus";
Skyler Grey1e2187f2023-03-03 22:45:10 +000099 group = "clicks";
100 shell = pkgs.bashInteractive;
101 };
Skyler Grey4f3e6062023-03-04 01:29:29 +0000102 users.users.websites = {
103 isSystemUser = true;
104 createHome = true;
105 home = "/services/websites";
106 group = "clicks";
107 shell = pkgs.bashInteractive;
108 };
109 users.groups.clicks = { };
Skyler Grey1e2187f2023-03-03 22:45:10 +0000110
111 programs.zsh.enable = true;
112 # List packages installed in system profile. To search, run:
113 # $ nix search wget
114 environment.systemPackages = with pkgs; [
115 vim # Do not forget to add an editor to edit configuration.nix! The Nano editor is also installed by default.
116 wget
117 ];
118
119 # Some programs need SUID wrappers, can be configured further or are
120 # started in user sessions.
121 # programs.mtr.enable = true;
122 # programs.gnupg.agent = {
123 # enable = true;
124 # enableSSHSupport = true;
125 # };
126
127 # List services that you want to enable:
128 nix.settings.experimental-features = [ "nix-command" "flakes" ];
129
130 # Enable the OpenSSH daemon.
131 services.openssh.enable = true;
Skyler Grey335bd902023-03-05 12:34:12 +0000132 services.openssh.settings.passwordAuthentication = false;
Skyler Grey1e2187f2023-03-03 22:45:10 +0000133
134 # Open ports in the firewall.
135 # networking.firewall.allowedTCPPorts = [ ... ];
136 # networking.firewall.allowedUDPPorts = [ ... ];
137 # Or disable the firewall altogether.
138 networking.firewall.enable = false;
139 networking.hostName = "Clicks";
140 # Copy the NixOS configuration file and link it from the resulting system
141 # (/run/current-system/configuration.nix). This is useful in case you
142 # accidentally delete configuration.nix.
143 /* system.copySystemConfiguration = true; */
144
145 # This value determines the NixOS release from which the default
146 # settings for stateful data, like file locations and database versions
147 # on your system were taken. It‘s perfectly fine and recommended to leave
148 # this value at the release version of the first install of this system.
149 # Before changing this value read the documentation for this option
150 # (e.g. man configuration.nix or on https://nixos.org/nixos/options.html).
151 system.stateVersion = "22.11"; # Did you read the comment?
152
153}