Add a setting to enable proxy protocol for streams

Change-Id: Ia15a18380624375ec4eb5d87d802df1e31f3c82d
diff --git a/nginx.nix b/nginx.nix
index a5e502c..47f05f8 100644
--- a/nginx.nix
+++ b/nginx.nix
@@ -176,8 +176,13 @@
      External should only be a port
      Protocol should be TCP or UDP
   */
+  ProxyStream = external: internal: protocol: {
+    inherit external internal protocol;
+    haproxy = true;
+  };
   Stream = external: internal: protocol: {
     inherit external internal protocol;
+    haproxy = false;
   };
 
   Alias = host: alias: {