Add a nix flake

This will allow us to use our helpers as a flake input

Change-Id: I5a03e0a9dbd2d76d10202f7657feea2dde1b1869
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..1dcca7b
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,7 @@
+{
+  description = "Clicks helpers for writing boilerplatey nix";
+
+  outputs = { self, nixpkgs }: {
+    helpers = import ./default;
+  };
+}