Add a '/' in a root directive for 'try_files'

try_files was leading to nginx not finding the file and erroring out with a
404. To remedy this, we need to add a root, which should be the root of our
filesystem. In this case this is safe because the path is hardcoded in our
config, so path traversal isn't possible as there is no user-controlled input.

We can't use an 'alias' directive, as that appends the http path to the
filesystem path, meaning that .well-known/matrix/client would become
/nix/store/.../config.jsonclient, which is no good

Change-Id: Ie1b0edbbb126c6cd6dcd8f0b4fd0cc829ee2b00c
diff --git a/nginx.nix b/nginx.nix
index 3ad045e..f229dbf 100644
--- a/nginx.nix
+++ b/nginx.nix
@@ -153,6 +153,7 @@
       else if service.type == "file" then
         (lib.recursiveUpdate currentConfig {
           value.locations.${currentPath} = {
+            root = "/";
             tryFiles = "${service.path} =404";
           };
         })