Add themeing to yyy_theme (depends on zzz_earlyload, must run before other stuff)
diff --git a/modules/neovim/yyy_theme/default.nix b/modules/neovim/yyy_theme/default.nix
new file mode 100644
index 0000000..4160599
--- /dev/null
+++ b/modules/neovim/yyy_theme/default.nix
@@ -0,0 +1,16 @@
+{ pkgs, ... }: {
+ programs.neovim = {
+ plugins = with pkgs.vimPlugins; [
+ onehalf
+ nvim-hlslens
+ pkgs.nvim-scrollbar
+ nvim-web-devicons
+ ];
+ extraConfig =
+ builtins.readFile ./theme.vim
+ + ''
+ source ${./scrollbar.lua}
+ source ${./icons.lua}
+ '';
+ };
+}