Create a basic repo outline
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..c4a49dc
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,20 @@
+{
+  description = "Minion's NixOS configuration (since 2022-08-19)";
+  inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
+  inputs.flake-utils.url = "github:numtide/flake-utils";
+
+  outputs = {
+    self,
+    nixpkgs,
+    flake-utils,
+  }:
+    flake-utils.lib.eachDefaultSystem (system: let
+      pkgs = nixpkgs.legacyPackages.${system};
+    in {
+      devShell = pkgs.mkShell {
+        nativeBuildInputs = with pkgs; [nodePackages.prettier alejandra];
+        buildInputs = [];
+      };
+      formatter = pkgs.alejandra;
+    });
+}