Need to call the package
diff --git a/src/home.nix b/src/home.nix
index 0baac4a..8afee27 100644
--- a/src/home.nix
+++ b/src/home.nix
@@ -12,7 +12,7 @@
         (self: (super: builtins.listToAttrs (
             map (f: {
                 name = builtins.elemAt (builtins.match "^(.*/)*(.*)\\.nix$" (toString f)) 1; 
-                value = super.lib.callPackageWith (self) (import f);
+                value = super.lib.callPackageWith (self) (import f) {};
             }) packages
         )))
     ];