Initial commit
diff --git a/system/packaging-configuration.nix b/system/packaging-configuration.nix
new file mode 100644
index 0000000..6ea58ea
--- /dev/null
+++ b/system/packaging-configuration.nix
@@ -0,0 +1,9 @@
+{ config, pkgs, options, ... }: {
+  # Apply custom packaging overlays for compatability
+  nix.nixPath =
+    # Prepend default nixPath values.
+    options.nix.nixPath.default ++
+    # Append our nixpkgs-overlays.
+    [ "nixpkgs-overlays=/etc/nixos/overlays/" ]
+  ;
+}