Use extraArgs
diff --git a/flake.nix b/flake.nix
index 0fa5d57..8027118 100644
--- a/flake.nix
+++ b/flake.nix
@@ -23,7 +23,11 @@
     in {
         nixosConfigurations = {
             default = nixpkgs.lib.nixosSystem {
-                inherit system nixpkgs;
+                inherit system;
+
+                extraArgs = {
+                  inherit nixpkgs;
+                }
 
                 modules = [
                     src/system.nix