Final commit; switching to new branch
diff --git a/.history/packages/com.googlesource.android.partition-tools.platform.system.extras/flake_20220302082759.nix b/.history/packages/com.googlesource.android.partition-tools.platform.system.extras/flake_20220302082759.nix
new file mode 100644
index 0000000..3057253
--- /dev/null
+++ b/.history/packages/com.googlesource.android.partition-tools.platform.system.extras/flake_20220302082759.nix
@@ -0,0 +1,21 @@
+{
+  description = "A flake to build android's partition-tools package";
+
+  inputs.nixpkgs.url = github:NixOS/nixpkgs/nixos-21.11;
+
+  outputs = { self, nixpkgs }: {
+
+    packages.x86_64-linux.partition-tools =
+      with import nixpkgs { system = "x86_64-linux"; };
+      stdenv.mkDerivation {
+        name = "partition-tools";
+        src = fetchurl { url = "https://android.googlesource.com/platform/system/extras/+archive/master/partition_tools.tar.gz"; hash = "sha256-bsO2QEcO9HuR4lZ6j+CmEIrvfT2YaynWvK4ZZLIv/CU="; };
+        unpackPhase = "tar xzf ${src}";
+        buildPhase = "tar xzf partition_tools.tar.gz && g++ -o out *.cc";
+        installPhase = "mkdir -p $out/bin && cp out/* $out/bin";
+      };
+
+    defaultPackage.x86_64-linux = self.packages.x86_64-linux.partition-tools;
+
+  };
+}