Automatically setup git remotes
diff --git a/modules/git.nix b/modules/git.nix
index 4482685..29e6bfd 100644
--- a/modules/git.nix
+++ b/modules/git.nix
@@ -43,6 +43,7 @@
         color.ui = "auto";
         core.autocrlf = "input";
         pull.rebase = "merges";
+        push.autoSetupRemote = true;
         credential.helper = "store";
         commit.signOff = true;
         core.splitIndex = true;