Add imperative cspell dictionary and views

- Vim views allow us to stay in the same place
- A cspell imperative dictionary lets us add words without having to rebuild
diff --git a/modules/neovim.nix b/modules/neovim.nix
index 4812584..864cee7 100644
--- a/modules/neovim.nix
+++ b/modules/neovim.nix
@@ -2,20 +2,24 @@
   pkgs,
   lib,
   home,
+  username,
   ...
 }: let
   utils = import ../utils lib;
 in {
   config = {
-    environment.variables = {
-      EDITOR = "nvim";
+    environment = {
+      variables = {
+        EDITOR = "nvim";
+      };
+      defaultPackages = [
+        pkgs.perl
+        pkgs.rsync
+        pkgs.strace
+        pkgs.neovim
+      ]; # The basic default packages, although with nvim replacing nano
+      persistence."/nix/persist".users.${username}.directories = [".local/share/cspell"];
     };
-    environment.defaultPackages = [
-      pkgs.perl
-      pkgs.rsync
-      pkgs.strace
-      pkgs.neovim
-    ]; # The basic default packages, although with nvim replacing nano
   };
 
   home = {