Add personal packages from previous home.nix
diff --git a/.history/flake_20220304134701.nix b/.history/flake_20220304134701.nix
new file mode 100644
index 0000000..e6fba26
--- /dev/null
+++ b/.history/flake_20220304134701.nix
@@ -0,0 +1,47 @@
+{
+    description = "Minion3665's NixFiles (since 2022-03-24)";
+
+    inputs = {
+        nixpkgs.url = "github:nixos/nixpkgs/nixos-21.11";
+        home-manager.url = "github:nix-community/home-manager/release-21.11";
+    };
+
+    outputs = { self, nixpkgs, home-manager }: {
+        let
+            system = "x86_64-linux";  # TOOD: Add options for MacOS
+
+            pkgs = nixpkgs {
+                inherit system;
+
+                config = { allowUnfree = true; };
+            };
+
+            variables = import ./src/common/variables.nix;
+        in {
+            nixosConfigurations = {
+                default = pkgs.lib.nixosSystem {
+                    inherit system;
+
+                    modules = [
+                        src/system.nix
+                    ];
+                }
+            };
+
+            homeManagerConfiguration = {
+                minion = home-manager.lib.homeManagerConfiguration rec {
+                    inherit system pkgs;
+
+                    username = "minion";
+                    homeDirectory = "/home/${username}";
+
+                    configuration = {
+                        imports = [
+                            src/home.nix
+                        ];
+                    }
+                }
+            }
+        };
+    };
+}