Add personal packages from previous home.nix
diff --git a/flake.nix b/flake.nix
index 94f2327..7329556 100644
--- a/flake.nix
+++ b/flake.nix
@@ -1,11 +1,47 @@
 {
-  description = "A very basic flake";
+    description = "Minion3665's NixFiles (since 2022-03-24)";
 
-  outputs = { self, nixpkgs }: {
+    inputs = {
+        nixpkgs.url = "github:nixos/nixpkgs/nixos-21.11";
+        home-manager.url = "github:nix-community/home-manager/release-21.11";
+    };
 
-    packages.x86_64-linux.hello = nixpkgs.legacyPackages.x86_64-linux.hello;
+    outputs = { self, nixpkgs, home-manager }: {
+        let
+            system = "x86_64-linux";  # TOOD: Add options for MacOS
 
-    defaultPackage.x86_64-linux = self.packages.x86_64-linux.hello;
+            pkgs = nixpkgs {
+                inherit system;
 
-  };
+                config = { allowUnfree = true; };
+            };
+
+            variables = import ./src/common/variables.nix;
+        in {
+            nixosConfigurations = {
+                default = pkgs.lib.nixosSystem {
+                    inherit system;
+
+                    modules = [
+                        src/system.nix
+                    ];
+                }
+            };
+
+            homeManagerConfiguration = {
+                minion = home-manager.lib.homeManagerConfiguration rec {
+                    inherit system pkgs;
+
+                    username = variables.username;
+                    homeDirectory = "/home/${username}";
+
+                    configuration = {
+                        imports = [
+                            src/home.nix
+                        ];
+                    }
+                }
+            }
+        };
+    };
 }