Update xmonad to use a better desktop portal
diff --git a/modules/xmonad.nix b/modules/xmonad.nix
index 0eca67a..9e051d2 100644
--- a/modules/xmonad.nix
+++ b/modules/xmonad.nix
@@ -28,10 +28,18 @@
         exec ${pkgs.systemd}/bin/systemd-cat -t xmonad ${pkgs.xorg.xinit}/bin/startx
       fi
     '';
-    home.file.".xinitrc".text = ''
+
+    home.file.".config/prelaunch/desktop-portals.sh".text = ''
       export XDG_DESKTOP_PORTAL_DIR=${pkgs.xdg-desktop-portal-gnome}/share/xdg-desktop-portal/portals
       ${pkgs.xdg-desktop-portal-gnome}/libexec/xdg-desktop-portal-gnome &
       ${pkgs.xdg-desktop-portal}/libexec/xdg-desktop-portal &
+    '';
+    home.file.".config/prelaunch/desktop-portals.sh".executable = true;
+
+    home.file.".xinitrc".text = ''
+      for file in ~/.config/prelaunch/*; do
+        $file &
+      done
       ${home.xsession.windowManager.command}
     '';
   };