Add cachix and some caches that I own
diff --git a/modules/cachix.nix b/modules/cachix.nix
new file mode 100644
index 0000000..7615ba1
--- /dev/null
+++ b/modules/cachix.nix
@@ -0,0 +1,16 @@
+{ pkgs, ... }: {
+  config.nix.settings = {
+    substituters = [
+      "https://nix-community.cachix.org"
+      "https://collabora.cachix.org"
+      "https://nixfiles.cachix.org"
+      "https://cache.nixos.org"
+    ];
+    trusted-public-keys = [
+      "hydra.nixos.org-1:CNHJZBh9K4tP3EKF6FkkgeVYsS3ohTl+oS0Qa8bezVs="
+      "collabora.cachix.org-1:e5DYzGux57BzidOmwCJ7NJgydrumaTWtVXdswnerMoU="
+      "nixfiles.cachix.org-1:QGVJNd+0aetjzU5l/MXrVg2adcrm9+8eL0HhIft3F+c="
+    ];
+  };
+  home.home.packages = [ pkgs.cachix ];
+}