Add some basic initial modules
diff --git a/modules/boot.nix b/modules/boot.nix
new file mode 100644
index 0000000..5905245
--- /dev/null
+++ b/modules/boot.nix
@@ -0,0 +1,8 @@
+{
+  config = {
+    boot.loader = {
+      systemd-boot.enable = true;
+      efi.canTouchEfiVariables = true;
+    };
+  };
+}