Enable neovim through home-manager
- We need to set the default editor to just "nvim" not a particular path, as
this allows us to override nvim in our home
- Add the mapleader bind to the start of init.vim
- As the leader is interpreted whenever we make a keybind, we must have it at
the start or it won't be respected for some of our keybinds (but will be for
others)
- Package the scrollbar plugin and install it
- Setup configs for stuff like treesitter, theme, COC, scrollbar etc.
- Add git capabilities to neovim
- Install fugitive, gitgutter and git-conflict, along with some other basic git
stuff
- Allow mouse control in neovim
diff --git a/modules/neovim/airline/default.nix b/modules/neovim/airline/default.nix
new file mode 100644
index 0000000..bd1d1ce
--- /dev/null
+++ b/modules/neovim/airline/default.nix
@@ -0,0 +1,18 @@
+{
+ pkgs,
+ lib,
+ ...
+}: {
+ programs.neovim = {
+ plugins = with pkgs.vimPlugins; [
+ airline
+ vim-airline-clock
+ ];
+ extraConfig = lib.pipe [./tabline.vim ./theme.vim ./parts.vim] [
+ (map builtins.readFile)
+ (builtins.concatStringsSep "\n")
+ ];
+ };
+
+ home.file.".config/nvim/autoload/airline/themes/onehalf.vim".source = ./onehalf-dark-airline.vim;
+}