Enable neovim through home-manager
- We need to set the default editor to just "nvim" not a particular path, as
this allows us to override nvim in our home
- Add the mapleader bind to the start of init.vim
- As the leader is interpreted whenever we make a keybind, we must have it at
the start or it won't be respected for some of our keybinds (but will be for
others)
- Package the scrollbar plugin and install it
- Setup configs for stuff like treesitter, theme, COC, scrollbar etc.
- Add git capabilities to neovim
- Install fugitive, gitgutter and git-conflict, along with some other basic git
stuff
- Allow mouse control in neovim
diff --git a/modules/neovim/zzz_earlyload/default.nix b/modules/neovim/zzz_earlyload/default.nix
new file mode 100644
index 0000000..bb2381d
--- /dev/null
+++ b/modules/neovim/zzz_earlyload/default.nix
@@ -0,0 +1,6 @@
+# The vim modules are sorted reverse alphabetically, so any extraConfig that is
+# put in here should hopefully be the first thing to be loaded. I'm using it to
+# set stuff like my mapleader
+{
+ programs.neovim.extraConfig = builtins.readFile ./settings.vim;
+}