Both system and home builds are now pure
diff --git a/flake.nix b/flake.nix
index aad38c5..94cd4f5 100644
--- a/flake.nix
+++ b/flake.nix
@@ -4,12 +4,14 @@
     inputs = {
         nixpkgs.url = "github:nixos/nixpkgs/nixos-21.11";
         home-manager.url = "github:nix-community/home-manager/release-21.11";
+        nurpkgs.url = "github:nix-community/NUR";
+        comma.url = "github:nix-community/comma";
 
         # Make sure flakes we depend on use the same version of nixpkgs as we do
         home-manager.inputs.nixpkgs.follows = "nixpkgs";
     };
 
-    outputs = { self, nixpkgs, home-manager }:
+    outputs = extraInputs@{ self, nixpkgs, home-manager, ... }:
     let
         system = "x86_64-linux";  # TOOD: Add options for MacOS
 
@@ -39,6 +41,8 @@
             minion = home-manager.lib.homeManagerConfiguration rec {
                 inherit system pkgs;
 
+                extraSpecialArgs = extraInputs;
+
                 username = variables.username;
                 homeDirectory = "/home/${username}";
                 stateVersion = variables.stateVersion;