Add jetbrains to here rather than having nix shell scripts; in future I want these to be installed in a separate profile but this is fine for now
diff --git a/src/apps/personal/jetbrains.nix b/src/apps/personal/jetbrains.nix
new file mode 100644
index 0000000..517a7c9
--- /dev/null
+++ b/src/apps/personal/jetbrains.nix
@@ -0,0 +1,35 @@
+{ pkgs, ... }: with pkgs; let 
+  webstorm = [
+    (jetbrains.webstorm.override { jdk = jdk11; })
+    nodejs-17_x
+    nodePackages.yarn
+  ];
+
+  pycharm = [
+    (jetbrains.pycharm-professional.override { jdk = jdk11; })
+    python310
+    python3Packages.numpy
+  ];
+
+  rider = [
+    jetbrains.rider
+    graphviz
+    mono
+    dotnet-sdk
+  ];
+
+  idea = [
+    jetbrains.idea-ultimate
+  ];
+
+  clion = [
+    jetbrains.clion
+    platformio
+  ];
+
+  goland = [
+    jetbrains.goland
+  ];
+in {
+  home.packages = webstorm ++ pycharm ++ rider ++ idea ++ clion ++ goland;
+}