Update the utils & allow importing as ./utils
- Previously imports would have to be done as ./utils/utils.nix
`import ./utils/utils.nix lib`
- This has now been simplified to just ./utils
`import ./utils lib`
diff --git a/utils/nixFilesInWithName.nix b/utils/nixFilesInWithName.nix
index 41bd157..7c56abc 100644
--- a/utils/nixFilesInWithName.nix
+++ b/utils/nixFilesInWithName.nix
@@ -3,4 +3,4 @@
map (name: {
inherit name;
path = dir + "/${name}";
-}) (lib.attrNames (lib.filterAttrs (name: _: lib.hasSuffix ".nix" name) (builtins.readDir dir)))
+}) (lib.attrNames (lib.filterAttrs (name: type: lib.hasSuffix ".nix" name && type == "regular") (builtins.readDir dir)))