Enable disk encryption of persistent partitions
diff --git a/modules/security.nix b/modules/security.nix
index d7bdbda..75ab2be 100644
--- a/modules/security.nix
+++ b/modules/security.nix
@@ -1,6 +1,18 @@
{
- config.security.apparmor = {
- enable = true;
- killUnconfinedConfinables = true;
+ config = {
+ security.apparmor = {
+ enable = true;
+ killUnconfinedConfinables = true;
+ };
+
+ boot.initrd.availableKernelModules = [
+ "aesni_intel"
+ "cryptd"
+ ];
+
+ boot.initrd.luks.devices = {
+ nix.device = "/dev/disk/by-label/nix";
+ swap.device = "/dev/disk/by-label/swap";
+ hdd.device = "/dev/disk/by-label/hdd";
};
}