Create template for direnv

nix-direnv's template is good, but it isn't quite perfect, particularly
- starting with pkgs.bashInteractive which we do not care about
- not being in this repository so none of our custom registry entries
  allow us to do templates#direnv
- there's no gitignore
- there's no formatter

Change-Id: Ia2d170624cc0eda2208cb39bd7c14046ca146492
Reviewed-on: https://git.clicks.codes/c/Templates/+/416
diff --git a/direnv/flake.nix b/direnv/flake.nix
new file mode 100644
index 0000000..5989b0f
--- /dev/null
+++ b/direnv/flake.nix
@@ -0,0 +1,17 @@
+{
+  description = "A Clicks project";
+  inputs.flake-utils.url = "github:numtide/flake-utils";
+
+  outputs =
+    { nixpkgs, flake-utils, ... }:
+    flake-utils.lib.eachDefaultSystem (
+      system:
+      let
+        pkgs = nixpkgs.legacyPackages.${system};
+      in
+      {
+        devShells.default = pkgs.mkShell { packages = [ ]; };
+	formatter = pkgs.nixfmt;
+      }
+    );
+}