Migrate global configuration to and expand home

- Move lots of system config to home (browser, editors, etc.)
- Improve catppuccin support (kitty, cursors, etc.)
- Improve overall theme (fonts, icons in kitty)
- Add coded's system hardware configuration ("shorthair")
- Add the ed editor
- Split minion's system hardware configuration ("greylag") into several files
- Improve shell support (aliases, useful packages, replacements, etc.)

Change-Id: Ie6d40f809b2662268a9a6fa8b241641bbfef9442
Reviewed-on: https://git.clicks.codes/c/Chimera/NixFiles/+/383
Tested-by: Skyler Grey <minion@clicks.codes>
Reviewed-by: Samuel Shuert <coded@clicks.codes>
diff --git a/homes/x86_64-linux/coded@shorthair/default.nix b/homes/x86_64-linux/coded@shorthair/default.nix
index d710c95..cfe6138 100644
--- a/homes/x86_64-linux/coded@shorthair/default.nix
+++ b/homes/x86_64-linux/coded@shorthair/default.nix
@@ -20,6 +20,10 @@
 }:
 {
   chimera = {
+    shell = {
+      rebuildFlakePath = "/home/coded/Documents/programming/nix/Personal";
+    };
+
     hyprland = {
       enable = true;
 
@@ -41,9 +45,7 @@
     browser = {
       firefox = {
         enable = true;
-        extraExtensions = [
-          config.nur.repos.rycee.firefox-addons.simple-tab-groups
-        ];
+        extraExtensions = [ config.nur.repos.rycee.firefox-addons.simple-tab-groups ];
       };
 
       chromium = {
@@ -59,9 +61,9 @@
           ublockOrigin.enable = true;
         };
         extraExtensions = [
-          { id = "gmkiokemhjjdjmpnnjmnpkpfoenpnpne"; } #Lofi Girl
-          { id = "bmnlcjabgnpnenekpadlanbbkooimhnj"; } #PayPal Honey
-          { id = "kekjfbackdeiabghhcdklcdoekaanoel"; } #MAL Sync
+          { id = "gmkiokemhjjdjmpnnjmnpkpfoenpnpne"; } # Lofi Girl
+          { id = "bmnlcjabgnpnenekpadlanbbkooimhnj"; } # PayPal Honey
+          { id = "kekjfbackdeiabghhcdklcdoekaanoel"; } # MAL Sync
         ];
       };
     };